Potential Fix for VMware Tools on Kernel 3.7.x

I’ve been struggling a lot with VMware tools on anything above Kernel 3.7.0 – for some reason it will not find the kernel headers no matter what you do. I may have found a potential fix and I am currently exploring it. If it does in fact work, I’ll post it here shortly.

Alright – here is the fix – I found this on a few other forums and tweaked it to worked with my kernel and actually really any other kernel you have that is 3.7.x – it’s a bug in the kernels code, not in how it’s compiled.

$ sudo cp /usr/src/linux-headers-3.7.0-2.dfk/include/generated/uapi/linux/version.h /lib/modules/3.7.0-2.dfk/build/include/linux/

you can replace that kernel version with whichever you have installed.